[Nowy Layout OCPL] Błędy i regresje

Wszystko co może pomóc w rozwoju serwisu opencaching.pl, sugestie, pomysły, także zauważone błędy

Moderator: Moderatorzy

Awatar użytkownika
deg
Rada Techniczna
Posty: 1104
Rejestracja: sobota 07 grudnia 2013, 04:31
Podziękował;: 224 razy
Otrzymał podziękowań: 498 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: deg »

parlando pisze: wtorek 23 stycznia 2018, 10:28 Po kliknięciu na mapę statyczną na stronie skrzynki wyświetla się puste okno bez mapy.
Najpierw popsułem, potem naprawiłem ;). Powinno działać.
Za ten post autor deg otrzymał podziękowanie:
parlando
"Kto ma rację dzień wcześniej od innych, ten przez dobę uchodzi za idiotę" Antoni de Rivarol
Obrazek

parlando
Forumator
Posty: 885
Rejestracja: poniedziałek 13 maja 2013, 20:57
Podziękował;: 341 razy
Otrzymał podziękowań: 182 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: parlando »

Działa.
Nie wiem, czy tak było wcześniej, ale jeśli założyć, że "sekcja" z mapką, kordami i statystykami (znalezienia, oceny itp) składa się z 3 kolumn, to zawartość każdej z tych kolumn zaczyna się na innym poziomie:
(najwyżej jest ikonka znalezień, następnie kompas i kordy, najniżej mapka) :)

Awatar użytkownika
PrincePolo
Stały bywalec
Posty: 93
Rejestracja: środa 18 lutego 2015, 21:11
Podziękował;: 23 razy
Otrzymał podziękowań: 25 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: PrincePolo »

Nie wyświetla mi się mapa skrzynek (mapa użytkownika). Przeglądarka Mozilla. Ktoś też tak ma?

Edit: Czasem działa, a czasem nie. Nie mam pojęcia dlaczego.
Obrazek ObrazekObrazek

parlando
Forumator
Posty: 885
Rejestracja: poniedziałek 13 maja 2013, 20:57
Podziękował;: 341 razy
Otrzymał podziękowań: 182 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: parlando »

PrincePolo pisze: środa 24 stycznia 2018, 10:12 Edit: Czasem działa, a czasem nie.
Nie wiem, czy o to chodzi, ale np. mapy geoportalu ładują się bardzo wolno. Najszybsze chyba są te googlowskie.

kojoty
Rada Techniczna
Posty: 335
Rejestracja: środa 26 listopada 2014, 14:14
Podziękował;: 14 razy
Otrzymał podziękowań: 213 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: kojoty »

PrincePolo pisze: środa 24 stycznia 2018, 10:12 Nie wyświetla mi się mapa skrzynek (mapa użytkownika). Przeglądarka Mozilla. Ktoś też tak ma?

Edit: Czasem działa, a czasem nie. Nie mam pojęcia dlaczego.
Opowiedz nam coś więcej:
- mówimy o mapie https://opencaching.pl/cachemap3.php - jaki dokładnie adres url?
- przeglądarka to mozilla firefox? jaka? najnowsza?na Windows?
- jak nie działa to co się dzieje - mógłbyś to dokładniej opisać?
- jeśli nie działa "czasem" to napisz coś więcej - jak często?

Pozdrowienia

kojoty
Rada Techniczna
Posty: 335
Rejestracja: środa 26 listopada 2014, 14:14
Podziękował;: 14 razy
Otrzymał podziękowań: 213 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: kojoty »

parlando pisze: środa 24 stycznia 2018, 10:59
PrincePolo pisze: środa 24 stycznia 2018, 10:12 Edit: Czasem działa, a czasem nie.
Nie wiem, czy o to chodzi, ale np. mapy geoportalu ładują się bardzo wolno. Najszybsze chyba są te googlowskie.
koledzy, żeby było wiadomo jak to działa:

mapa OC składa się z 2 warstw:
- warstwy keszowej - to są przezroczyste, kwadratowe kafelki, na których są wyłącznie ikonki keszy generowane przez OKAPI na serwerze OC
- warstwy mapki - gdzie kafelki mapy sa sciągane z zewn. serwisu udostępniającą takie usługi np google, OSM czy geoportalu (i są ściągane bezpośrenio - czyli ściąga je przeglądarka a nie serwer OC)

zatem:
- jeśli nie ładuje się strona - problem może być po stronie OC
- jeśli nie ładują się kafelki z keszami - prawie na pewno problem po stronie OC
- jeśli nie ładuja się kafekli z mapką - problem prawie na pewno nie leży po stronie OC - po prostu nie działa zewn. serwis, działa wolno lub połaczenie jest kiepskie albo cokolwiek innego, ale OC nie ma na to (na ogół) wpływu.

Awatar użytkownika
deg
Rada Techniczna
Posty: 1104
Rejestracja: sobota 07 grudnia 2013, 04:31
Podziękował;: 224 razy
Otrzymał podziękowań: 498 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: deg »

PrincePolo pisze: środa 24 stycznia 2018, 10:12 Nie wyświetla mi się mapa skrzynek (mapa użytkownika).
Już powinno działać. Sprawdź.
Za ten post autor deg otrzymał podziękowanie:
PrincePolo
"Kto ma rację dzień wcześniej od innych, ten przez dobę uchodzi za idiotę" Antoni de Rivarol
Obrazek

Awatar użytkownika
PrincePolo
Stały bywalec
Posty: 93
Rejestracja: środa 18 lutego 2015, 21:11
Podziękował;: 23 razy
Otrzymał podziękowań: 25 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: PrincePolo »

deg pisze: środa 24 stycznia 2018, 15:30
PrincePolo pisze: środa 24 stycznia 2018, 10:12 Nie wyświetla mi się mapa skrzynek (mapa użytkownika).
Już powinno działać. Sprawdź.
Przepraszam, ale dopiero teraz mogłem wejść na forum.
Mapa już działa bez zarzutu, dzięki.
Obrazek ObrazekObrazek

Awatar użytkownika
Moris299
Bywalec
Posty: 60
Rejestracja: poniedziałek 30 grudnia 2013, 20:54
Podziękował;: 4 razy
Otrzymał podziękowań: 25 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: Moris299 »

Dzisiaj mam problemy z działaniem całego serwisu. Co chwilę wyskakuje błąd łączenia z serwerem. C:geo na telefonie dziewczyny też nie mogło się połączyć z oc a gc łączyło bez problemu.
Jakieś większe problemy z serwerem czy co?
Problem występuje raz na jakiś czas ,potem na chwilę jest ok a potem znowu pada.

Edit:
http://imgur.com/7PvTF1e
http://imgur.com/kJb5BKN
Obrazek Obrazek

Awatar użytkownika
dallas
Wyjadacz
Posty: 442
Rejestracja: czwartek 21 czerwca 2012, 22:17
Podziękował;: 100 razy
Otrzymał podziękowań: 153 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: dallas »

Ja też mam dość regularne zwiechy całego serwisu trwające około minuty (ostatnia około 22.57). Inne strony działają w tym czasie poprawnie. Pojawiają się nieregularnie i niezależnie od ilości osób na stronie.

Awatar użytkownika
deg
Rada Techniczna
Posty: 1104
Rejestracja: sobota 07 grudnia 2013, 04:31
Podziękował;: 224 razy
Otrzymał podziękowań: 498 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: deg »

Serwer przez ten czas działał stabilnie, nie był przeciążony, w logach niczego podejrzanego nie znaleźliśmy. Ponieważ w chwilach "zwiechy" nie działały żadne usługi serwera - prawdopodobnie wina tkwi po stronie dostawcy infrastruktury i internetu dla OC PL (IQ Net). W każdym razie w nocy z piątku na sobotę wszystko wróciło do normy bez naszej ingerencji.

PS: Moje PRYWATNE zdanie o tym dostawcy świetnie ujęła Kasia Nosowska w piosence "Niekoniecznie o mężczyźnie" :)
"Kto ma rację dzień wcześniej od innych, ten przez dobę uchodzi za idiotę" Antoni de Rivarol
Obrazek

Azymut
Stały bywalec
Posty: 125
Rejestracja: środa 16 września 2015, 23:10
Podziękował;: 43 razy
Otrzymał podziękowań: 104 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: Azymut »

Coś się sypnęło w skumulowanej ilości znalezień: https://opencaching.pl/articles.php?page=s2
Do tej pory po wejściu w link automatycznie ładowała się strona z pełnymi statystykami wszystkich zaliczonych przez użytkowników skrzynek. Obecnie po wejściu w link nie wyświetlają się te statystki i żeby zobaczyć jakiekolwiek statystyki trzeba zaznaczyć któreś z pól "Nie licz statystyk" (przy czym to też nie zawsze działa).

Awatar użytkownika
deg
Rada Techniczna
Posty: 1104
Rejestracja: sobota 07 grudnia 2013, 04:31
Podziękował;: 224 razy
Otrzymał podziękowań: 498 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: deg »

Azymut pisze: poniedziałek 05 lutego 2018, 00:47 Coś się sypnęło w skumulowanej ilości znalezień: https://opencaching.pl/articles.php?page=s2
Nie odświeżaj tak często, to będzie chodziło dobrze ;). A jeśli się popsuło, to za godzinę samo powinno się naprawić. Takie czary.
A tak całkiem na poważnie, to większość statystyk jest do zaorania i napisania od nowa. Tylko kiedy?

@kojoty: wygląda na problem z APCu. Czyżby ten sam co z feedami?
"Kto ma rację dzień wcześniej od innych, ten przez dobę uchodzi za idiotę" Antoni de Rivarol
Obrazek

kojoty
Rada Techniczna
Posty: 335
Rejestracja: środa 26 listopada 2014, 14:14
Podziękował;: 14 razy
Otrzymał podziękowań: 213 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: kojoty »

deg pisze: poniedziałek 05 lutego 2018, 01:31
Azymut pisze: poniedziałek 05 lutego 2018, 00:47 Coś się sypnęło w skumulowanej ilości znalezień: https://opencaching.pl/articles.php?page=s2
Nie odświeżaj tak często, to będzie chodziło dobrze ;). A jeśli się popsuło, to za godzinę samo powinno się naprawić. Takie czary.
A tak całkiem na poważnie, to większość statystyk jest do zaorania i napisania od nowa. Tylko kiedy?

@kojoty: wygląda na problem z APCu. Czyżby ten sam co z feedami?
sorki, nie wiem o co chodzi - aktualnie wydaje się, że działa normalnie.
Staty - coż - jak pół serwisu wołają o refaktor - ja kończę aktualnie listę z notatkami w keszach, Na tą statystykę postaram się zerknąć. Zobaczymy.

BTW: Panowie, nie znam się na forach, bo ja w ogóle się mało znam, ale wytłumaczcie mi bo od zawsze mnie to nurtuje:
Czemu musimy mieć zbiorczy wątek na takie problemy i on ma 86 podstron? Nie można by zakładać wątku per-problem?

Awatar użytkownika
krystiant
Forumator
Posty: 1976
Rejestracja: środa 29 października 2008, 23:55
Podziękował;: 121 razy
Otrzymał podziękowań: 403 razy

Re: [Nowy Layout OCPL] Błędy i regresje

Post autor: krystiant »

kojoty pisze: poniedziałek 05 lutego 2018, 12:56Staty - coż - jak pół serwisu wołają o refaktor
To komu trzeba by nogę połamać :mrgreen:
Poczytaj zanim się zapytasz :wink:
Proszę o przemyślane wypowiedzi zgodne z REGULAMINEM FORUM a w szczególności z punktem 11

Obrazek Obrazek Obrazek
Staram się zachowywać właściwe proporcje - znalezień więcej niż postów ;-)

ODPOWIEDZ